windows server 2008 R2 系统中 安装 neo4j-community-4.2.1版本, 不能启动
发布于 2 年前 作者 hfyang 2145 次浏览 来自 问答

图片.png Invoke-Neo4j : 无法对参数“ArgumentList”执行参数验证。该参数为 Null、为空或参 数集合的某个元素包含 Null 值。请提供一个不包含任何 Null 值的集合,然后重试此命 令。 所在位置 G:\neo4j-community-4.2.1\bin\neo4j.ps1:30 字符: 19

  • Exit (Invoke-Neo4j <<<< -Verbose:$Arguments.Verbose -Command $Arguments.Args )
    • CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep tion
    • FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio n,Invoke-Neo4j
9 回复

好的 多谢,我试试

@pangguoming 庞老师,检查了环境变量,Powershell已经配置了,问题还是这样木有解决。。还有啥办法排查吗

我也是这个问题,请问最后是怎么解决的?

@1254812107 用管理员身份运行 CMD命令行窗口 试试

@pangguoming 您好,还是没办法解决

@memory_717 https://neo4j.com/docs/operations-manual/current/installation/windows/ 上文档中说需要powershell版本 一般需要在2及以上 但是我试了2也不行 我升级到了3 步骤如下: 开始菜单 输入$host 查询powershell版本 如果不是需要升级 更新路径如下 https://download.microsoft.com/download/E/7/6/E76850B8-DA6E-4FF5-8CCE-A24FC513FD16/Windows6.1-KB2506143-x64.msu

@1254812107 https://neo4j.com/docs/operations-manual/current/installation/windows/ 上文档中说需要powershell版本 一般需要在2及以上 但是我试了2也不行 我升级到了3 步骤如下: 开始菜单 输入$host 查询powershell版本 如果不是需要升级 更新路径如下 https://download.microsoft.com/download/E/7/6/E76850B8-DA6E-4FF5-8CCE-A24FC513FD16/Windows6.1-KB2506143-x64.msu

回到顶部